Author Topic: unreadable button text of TrIDNet with ReactOS  (Read 1456 times)

jenderek

  • Full Member
  • ***
  • Posts: 102
unreadable button text of TrIDNet with ReactOS
« on: April 07, 2018, 01:05:02 AM »
Hello,

some days ago i tried to to run newest TrIDNet.exe version 1.95 under
operating system ReactOS, but the text on buttons is unreadable ( see
appended picture tridnet-reactos-1.png). Clicking on button works as
expected ( see appended picture tridnet-reactos-2.png).

But error search is like looking for needle in hay stack. The
composition of button text maybe depend on so many factors. Some i can
not influence.

So here is my configuration and what i tried. My physical screen has a
resolution 2560x1140x32 with 150% scaling and is connected with an
on board Intel HD Graphics 4600.

I run ReactOS only on a virtual machine. The used virtualisation
software is Virtual box. I tried some different version of that
software. Latest i tried was 5.2.8. My used virtual screen has a
resolution of 1280x1024x32 with 2d-acceleration. I first thought that
error maybe depends on error in virtualisation software. But running
TrIDNet with Windows inside virtual machine words fine. It also works
with WINE emulator on Linux. So i came to conclusion that error is
probably not affected by virtualisation software.

My next thought was that error is influenced by bugs inside operating
system ReactOS. I tried version 0.4.3 and most other software like
web browser and file managers are running stable. I have also tried newer
versions like 0.4.6, but in the newer versions the OS itself is for me
too unstable, so i do not spend more efforts to run software on that
versions at the moment.

TrIDNet application depends on .NET Framework. That fact is also
mentioned on website http://mark0.net/soft-tridnet.html . Unfortunately
there nothing is said about version dependency. The modern Windows OS
already contain new .NET Frameworks, but ReactOS is not a Microsoft
product. So it does not contain any .NET Frameworks. So .NET libraries
must be installed separately. The application manager of ReactOS offers
different versions. First i tried to install Version 1.1, but this
fails.  Then i installed version 2.0 with Service Pack 2. That
installation succeeds but the libraries are dated about summer 2008. So
maybe that framework is too old and is maybe not compatible with
TrIDNet. The application manager offers also a newer version 4.0 .NET
Framework. But after some days of frustrating efforts i do not want to try
to install more existing library versions (like 3.5, 4.0, 4.5, etc.).

The text on software elements concerning file name path are readable,
but not the text on buttons like "Browse", "Analyze!" and "Rescan Defs".
So i tried to change appearance of ReactOS. In control panel i changed
size and colour of elements. For some elements i can also change font
and font size. But all my desperate changes do not effect buttons.  But
there exist so many element types, that i only tried element types, that
seems to be reasonable for me and skipped unlike types like "scroll
bar".

So has anybody run TrIDNet with ReactOS and has readable text on
buttons? If the answer is yes then i would be pleased to get information
about used configuration settings.
Or has anybody some tips and tricks that i could try to fix the problems.

thanks for helpful hints
J?rg Jenderek