Author Topic: no definition file without FrontBlock for GIMP animated brush (*.gih)  (Read 383 times)


  • Full Member
  • ***
  • Posts: 135
Hello Marco,

some days i run trid on GIMP animated brush, that have
file name extension gih. Such files are not recognized and often
described as "Unknown!" ( see appended output/trid-old.txt).

So i run tridscan on dozen of examples. Some information about such
brushes is found on fileformats archiveteam website. This is expressed
by line:


According to that information i cleaned up Global strings section to
contains only lines

   <String>CONSTANT RANK0</String>

The refined definition file gimp-gih.trid.xml contains in FrontBlock
section only one XML construct:


According to reference site there should not exist a specific byte
pattern at a fixed offset. So i tried to cleanup definition file by
adding more samples by a command like -fs -d gimp-gih.trid.xml  more\brush_dan2.gih

But program executes and and ends with an error message like

   TrIDScan/Py v2.02 - (C) 2015-2016 By M.Pontello
   File(s) to scan found: 1
   Scanning for patterns...
   Checking file 1/1 'more\brush_dan2.gih' Error: no patterns found!

The same error occurs when i try to add other brush examples inside
"more" sub directory.

Then i try to refine definition file by deleting pattern inside
FrontBlock section manually which results in gimp-gih-2.trid.xml.
But after packing the XML file by TrIDDefsPack the resulting TRD file
does produce only output with "Unknown!" description.

So what is wrong? Please can you try to generate a working definition
definition file for GIMP animated brushes? TrID definitions affords,
some examples and output are stored in archive

Thanks in advance
Jörg Jenderek


  • Administrator
  • Hero Member
  • *****
  • Posts: 2036
    • Mark0's Home Page
Re: no definition file without FrontBlock for GIMP animated brush (*.gih)
« Reply #1 on: October 14, 2019, 11:36:00 PM »
If there are no fixed patterns, and so there's no/empty FrontBlock, it's not a viable format to be recognized with TrID, I'm afraid.